Supported Versions of Exchange and System Requirements

What versions of Microsoft Exchange Server are supported by GOexchange?
 GOexchange currently supports Microsoft Exchange server versions 2013, 2010, 2007, 2003, 2000 and 5.5
Sat, 22 Apr, 2017 at 4:44 PM
Does GOexchange support Microsoft Exchange Database Avaialbility Groups & Clustering?
GOexchange supports Microsoft Exchange Database Availability Groups (DAGs) for Exchange 2010 and 2013 Microsoft Exchange Active/Passive and Acti...
Thu, 7 Jan, 2016 at 11:09 AM
What are the system requirements for GOexchange?
This questions requires a more in-depth answer which you can find by clicking on the links below. Server System Requirements Cli...
Thu, 7 Jan, 2016 at 11:12 AM