Problem Overview

During a DigiScope restoration you receive the error "An item with the same key has already been added" as shown in the dialog below.   




Cause

if an Exchange Server object such as a Mailbox or Public Folder has the same LegacyExchangeDN value as another Exchange Server object located within the same Exchange database and DigiScope attempts to access that object it will throw the "An item with the same key has already been added" error message.  This more then likely occurred when someone manually updated the value of several objects and inadvertently duplicated the values. 


Resolution

WARNING - ADSI Edit is a very powerful utility that should be used with extreme caution

Lucid8 is providing the information herein as sample reference material ONLY. If you use ADSI Edit to make modifications you do so at your own risk. Incorrect modifications of Active Directory objects attributes can cause serious problems.


1. Open ADSI edit from either the Exchange Server, or a domain controller.


2. Navigate to the container that holds the Mailbox or Public Folders objects you cannot access with DigiScope.  Usually this is the CN=Users "Container" as shown in the example below.



3. Navigate to the Mailbox or Public Folder object you were attempting to access when the error occurred. Right-click and select properties as shown in the example below.



4. Starting typgin the name of the Attribute i.e. "Legacy" and the value will be highlighted or simply scroll down the list of attributes until you find the LegacyExchangeDN Attribute as shown in the example below.



5. Select the LegacyExchangeDN Attribute. Click Edit, the String Attribute Editor Dialog appears.


 


6. Click in the Value field, Press CTRL+A to select all and then CTRL+C to copy the string into the clipboard.


7. Now that we have the attribute of the object we are having issue accessing we need to determine what other objects have this same value. ADSI Edit does not have the ability to query AD objects, therefore open Active Directory Users and Computers (ADUC) as shown below.



8. Navigate to the top of the domain as shown above, right-click and select "Find..." as shown in the example below



9. The "Find Users, Contacts, and Groups Dialog appears.



10. Paste the contents of the clipboard within the NAME field (CTRL+V).

11. Click Find Now and the objects with the same value will appear as shown in our example below.



12. Edit the appropriate object and correct the value.  For example in our test case the Pilar Ackerman and Public Folders object clearly have the same LegacyExchangeDN value. While you could simply modify one of the objects LegacyExchangeDN value to resolve the issue, that value is used in other ways and its best to ensure the value is the correct one.  For more information on how LegacyExchangeDN is utilized check out the DigiScope documentation section titled "Cannot Reply to Old Emails or Modify Calendar Items Post Migration"


13. For our test case here within this solution article we updated the Pilar Ackerman mailbox object with the correct value and the issue was resolved.


SUPPORT: If you experience issues, have questions or need assistance after following these instructions please Open a New Support Ticket or if you already have a ticket open reply with details and we will be happy to assist.  That said, Lucid8 is providing the information herein as a courtesy. This article is not intended to be nor imply a service contract to resolve Microsoft related issues involving ADSI Edit and providing you with this information does not commit Lucid8 to support or assist with any Microsoft related features, capabilities or responsibilities. To say it another way, this article is here to help you resolve the issue as quickly as possible.  However if your Exchange environment does not respond to the adjusted settings or if you have other Exchange related issues we are not obligated to assist unless you engage Lucid8 under a "Paid Professional Services Agreement"